Warning bleep & service light fault - FIX

If you have a Tip or Trick, some advice or you just want others to know something that is not specific to the fuel a Citroen C3 uses, please, post it here. Manual Gearbox, bodywork, interior, wheels and tyres are all welcome here.
Forum rules
Tips for any Citroen C3

Tips from forum members are encouraged and very welcome.

Questions are not to be posted in this section

No Engine tips

Think: Manual Gearbox, Bodywork, Lighting, Interior, Wheels, Steering, Brakes and Suspension
My Name: Pjkingham

Member
Posts: 1
Joined: Sat Jul 12, 2014 5:01 pm
Model: C3 2006-2009, Facelift model
Year: 2008 (08)
Engine Size: 1.6 i
Fuel Type: Diesel
Mileage: 100000
Trim Level: VTR+
Gearbox: Manual 5 speed
DPF: Yes

Post

Like many others I have an electrical problem with my C3,it is a 2008 exclusive plus model. When I apply the brakes or signal to turn right I get a bleep, & service light comes on. I have found a way to solve this problem. Simply turn on the lights, it does not happen then at all. I know from reading that this is quite a common problem which can be very expensive to solve. So give it a try. It works 100% on my car. I hope it helps others annoyed with the constant bleeping.



Image
User avatar
My Name: C3CAR

Guru
Posts: 2661
Joined: Wed May 04, 2011 10:01 am
Model: C3 2002-2005, Original shape model
Year: 2002 (02)
Engine Size: 1.4 (16v)
Fuel Type: Diesel
Mileage: 140000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: DV4 16-valve diesel (90 PS)
Has thanked: 176 times
Been thanked: 93 times

Post

Pjkingham wrote:Like many others I have an electrical problem with my C3,it is a 2008 exclusive plus model. When I apply the brakes or signal to turn right I get a bleep, & service light comes on. I have found a way to solve this problem. Simply turn on the lights, it does not happen then at all. I know from reading that this is quite a common problem which can be very expensive to solve. So give it a try. It works 100% on my car. I hope it helps others annoyed with the constant bleeping.
Thank you Pjkingham

I suspect you have a faulty COM2000 unit (steering wheel switch unit here). The tracks and cables get worn or damaged over time usage, i suspect you are moving the faulty connection by moving a switch.

You can see the COM2002 repair guide in this topic (here).
  • Similar Topics
    Replies
    Views
    Last post