Sensodrive loses drive and would not select any gears or start

If you have a Tip or Trick, some advice or you just want others to know something that is specific to the a Citroen C3 with an automatic gear-box , please, post it here. Includes the 4 speed AL4 with PRND and the 5 speed semi-automatic (SensoDrive) with '+ and -' controls.
Forum rules
Tips for a Citroen C3 with an Automatic Gear Box

Tips from forum members are encouraged and very welcome.

Questions are not to be posted in this section

Think: Auto not changing up or down, snowflake and sport flashing, flappy paddles and sensodrive not changing gear.
My Name: chesnuts

Member
Posts: 2
Joined: Fri Aug 22, 2014 10:03 pm
Model: C3 2002-2005, Original shape model
Year: 2003 (53)
Engine Size: 1.6 (16v)
Fuel Type: Petrol
Mileage: 69000
Trim Level: VTR+
Gearbox: SensoDrive
DPF: No

Post

Hi all, I have been having an issue with a sensodrive C3. 53 Plate done 69k. It has a fault where it loses drive and would not select any gears or start etc, all the usual that you have probably read about..... Also when it was running it would stall as the clutch would not always engage as it came to a standstill. It constantly had the snowflake and - sign.
User avatar
My Name: C3CAR

Guru
Posts: 2659
Joined: Wed May 04, 2011 10:01 am
Model: C3 2002-2005, Original shape model
Year: 2002 (02)
Engine Size: 1.4 (16v)
Fuel Type: Diesel
Mileage: 140000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: DV4 16-valve diesel (90 PS)
Has thanked: 176 times
Been thanked: 93 times

Post

chesnuts wrote:Hi all, I have been having an issue with a sensodrive C3. 53 Plate done 69k. It has a fault where it loses drive and would not select any gears or start etc, all the usual that you have probably read about..... Also when it was running it would stall as the clutch would not always engage as it came to a standstill. It constantly had the snowflake and - sign.

I first found water ingress in the gearbox ECU connector causing corrosion across terminals. I cleaned and refit making it more reliable but issues were still there. I then removed and opened up the gearbox ECU and found a current flow resistor that had burnt out on the board, replaced that, no different.
I have now removed and striped down the clutch actuator, I have found the the adjuster assembly where it fits into the ball socket is loose and the ball socket has worn away. When the clutch is in its closed position you should be able to push the adjuster and it will retract, when its worn like this it wont..

Lexia was coming up with fault codes..but the main one I think that is the root of the issue is P1755 PERMANENT FAULT, Incorrect position in relation to the reference value coherence.
I am guessing, but I think it may be down to the worn part in the actuator...

Now I am going to Citroen to see if I can buy the parts to repair the actuator..(Don't really wish to buy a new clutch actuator for the sake of one plastic socket).
Then when that is resolved I am going to fit a new clutch. I, sure that when this is done the gearbox will be serviceable yet again...
Hope this helps someone.

Attached picture shows the socket where the ball of the adjuster fits, this is where it s badly worn causing it to stick.
Sensodrive Clutch Actuator worn part
Sensodrive Clutch Actuator worn part
Thank you for all the useful information!
My Name: chesnuts

Member
Posts: 2
Joined: Fri Aug 22, 2014 10:03 pm
Model: C3 2002-2005, Original shape model
Year: 2003 (53)
Engine Size: 1.6 (16v)
Fuel Type: Petrol
Mileage: 69000
Trim Level: VTR+
Gearbox: SensoDrive
DPF: No

Post

Sorted. If you need any help with a senso drive issue drop me a message.
  • Similar Topics
    Replies
    Views
    Last post