Radio not saving new Bluetooth pairings after battery swap

Audio, ICE, Speakers, Head Unit, CD, CD Multi changer. If you have a question about any Citroen C3 related Audio, then this is the place.

Please indicate if there is a Citroen CD multi-changer, drawer or cubby under the CD/Radio, if there is the Navigation unit, CD or Radio options.
Forum rules
Only post questions about AUDIO equipment in this topic please. In car entertainment, ICE, Android Auto, stereo and sat-nav are all welcome here
My Name: rhodriowens

Member
Posts: 1
Joined: Sat May 08, 2021 4:36 pm
Model: C3 2009-2013, New shape (A51)
Year: 2012 (62)
Engine Size: 1.4
Fuel Type: Diesel
Mileage: 84000
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: DV4 diesel (70 PS)

Post

The battery in my car recently died so I've had it replaced, the car is functioning fine after doing so except that the radio isn't saving new paired Bluetooth devices.

At about the same time I've upgraded to a new phone, so have tried to pair the new phone to the car.

I can pair the new phone to it, and it works, but after turning the car off and then turning it back on again the phone doesn't show in the paired devices list, and the phone itself just asks for the PIN to pair again.

In the list of paired devices my old phone appears and if I delete it then it disappears, but when the car is restarted that reappears in the list too.

Not sure if this is something that anyone else has ever seen, I've been searching for a while but can't find any reports of something similar.
User avatar
My Name: C3driver52

Guru
Posts: 1854
Joined: Sat Apr 30, 2011 7:40 pm
Model: C3 2002-2005, Original shape model
Year: 2003 (03)
Engine Size: 1.4 i
Fuel Type: Petrol
Mileage: 79984
Trim Level: VTR+
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: TU3 (75 PS)
Has thanked: 85 times
Been thanked: 65 times

Post

rhodriowens wrote: Sat May 08, 2021 4:42 pm The battery in my car recently died so I've had it replaced, the car is functioning fine after doing so except that the radio isn't saving new paired Bluetooth devices.

At about the same time I've upgraded to a new phone, so have tried to pair the new phone to the car.

I can pair the new phone to it, and it works, but after turning the car off and then turning it back on again the phone doesn't show in the paired devices list, and the phone itself just asks for the PIN to pair again.

In the list of paired devices my old phone appears and if I delete it then it disappears, but when the car is restarted that reappears in the list too.

Not sure if this is something that anyone else has ever seen, I've been searching for a while but can't find any reports of something similar.
I've not heard of this before.

You could try disconnecting the battery again and leave it for a while, then reconnect it.

Only because this is what probably started the problem and it does sound like a software issue.
My Name: Lbanks44

Member
Posts: 1
Joined: Thu Aug 05, 2021 9:47 am
Model: Other
Year: 2014 (14)
Engine Size: 1.4
Fuel Type: Diesel
Mileage: 67000
Trim Level: Other
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)

Post

Anyone have any answer to this please? I’ve bought a car with the same problem?
  • Similar Topics
    Replies
    Views
    Last post