Aftermarket Radio, no sound

Audio, ICE, Speakers, Head Unit, CD, CD Multi changer. If you have a question about any Citroen C3 related Audio, then this is the place.

Please indicate if there is a Citroen CD multi-changer, drawer or cubby under the CD/Radio, if there is the Navigation unit, CD or Radio options.
Forum rules
Only post questions about AUDIO equipment in this topic please. In car entertainment, ICE, Android Auto, stereo and sat-nav are all welcome here
My Name: Torn

Member
Posts: 2
Joined: Thu Aug 12, 2021 3:54 pm
Model: C3 2006-2009, Facelift model
Year: 2008 (08)
Engine Size: 1.6
Fuel Type: Diesel
Mileage: 80000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: Yes
LHD or RHD: RHD (UK)

Post

Hi!

I recently bought my 2008 C3 and decided to change the radio. I got a Pioneer MVH-S420BT and harness from halfords to replace the orignal radio with. When i connected them, i got sound for about 2 mins untill it completely cut off and now im getting no sound at all from it. I tried my orignal radio, that works fine with both FM radio and CD. I tried a completely different radio, that doesnt work either. I bought the correct harness and the MVH-S420BT works fine in other cars.

Im wondering if anyone else has had a similer issue or could pin point the problem.
User avatar
My Name: Arfur Dent

Guru
Posts: 3441
Joined: Sat Jul 23, 2011 3:47 pm
Model: C3 2002-2005, Original shape model
Year: 2002 (52)
Engine Size: 1.4 (16v)
Fuel Type: Diesel
Mileage: 100000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: DV4 16-valve diesel (90 PS)
Has thanked: 320 times
Been thanked: 121 times

Post

Torn wrote: Thu Aug 12, 2021 4:01 pm Hi!

I recently bought my 2008 C3 and decided to change the radio. I got a Pioneer MVH-S420BT and harness from halfords to replace the orignal radio with. When i connected them, i got sound for about 2 mins untill it completely cut off and now im getting no sound at all from it. I tried my orignal radio, that works fine with both FM radio and CD. I tried a completely different radio, that doesnt work either. I bought the correct harness and the MVH-S420BT works fine in other cars.

Im wondering if anyone else has had a similer issue or could pin point the problem.
Hi

When you say 'no sound', do you mean it powers up and you can select a source, set the volume but just no sound on any of the speakers when you fade and balance to each of the 4 corners?

Or it is just dead, no power, no lights.


You didn't say *which* harness you used :?:
You can add an avatar to your account - Avatar or change your vehicle details - Car Bio or even add a signature to your posts - Signature. But this is not all you can do in the User Control Panel :)
My Name: Torn

Member
Posts: 2
Joined: Thu Aug 12, 2021 3:54 pm
Model: C3 2006-2009, Facelift model
Year: 2008 (08)
Engine Size: 1.6
Fuel Type: Diesel
Mileage: 80000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: Yes
LHD or RHD: RHD (UK)

Post

The radios on, the lights are all there and I can change any source or setting. The harness I bought was a c3 compatible one from Halfords, I can't find a link to the exact one on their website.

I've tried both the aux and Bluetooth sources on the radio and no sound is coming from the speakers.
  • Similar Topics
    Replies
    Views
    Last post