Occasional EML and limp mode

Questions specifically about a Petrol powered Citroen C3 (usually engine or fuel related problems).
Forum rules
One question per topic.
Petrol engine related faults, like injectors, error codes, overheating.
You can post more topics if necessary, but only one question per topic.
My Name: gjb02storm

Contributor
Posts: 7
Joined: Tue Nov 21, 2017 7:48 pm
Model: C3 2002-2005, Original shape model
Year: 2003 (03)
Engine Size: 1.4 (8v)
Fuel Type: Petrol
Mileage: 112000
Trim Level: SX
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: TU3 (75 PS)

Post

I have a 2003 1.4 petrol Auto that has an odd fault. It will drive perfectly for 99% of the time however, when coming off a roundabout the car beeps and goes into limp mode. The fault code leads back to the motorised throttle short to earth of open circuit.
I've swapped the throttle for a known good throttle and the fault was still replicated.
Revs are low and the gears have changed, I've turned one way and then the other, go to accelerate away and beep. Low power limp mode. It clears after I cycle the ignition.
I can't test for it when static because it is fine. It only happens in a dynamic situation.

I have a suspicion that it may be a bad earth or a cable that is pulled when I turn the corners of a roundabout. Anybody had any similar faults??
User avatar
My Name: Arfur Dent

Guru
Posts: 3308
Joined: Sat Jul 23, 2011 3:47 pm
Model: C3 2002-2005, Original shape model
Year: 2002 (52)
Engine Size: 1.4 (16v)
Fuel Type: Diesel
Mileage: 100000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: DV4 16-valve diesel (90 PS)
Has thanked: 259 times
Been thanked: 112 times

Post

gjb02storm wrote: Sun Jul 22, 2018 4:00 pm I have a 2003 1.4 petrol Auto that has an odd fault. It will drive perfectly for 99% of the time however, when coming off a roundabout the car beeps and goes into limp mode. The fault code leads back to the motorised throttle short to earth of open circuit.
I've swapped the throttle for a known good throttle and the fault was still replicated.
Revs are low and the gears have changed, I've turned one way and then the other, go to accelerate away and beep. Low power limp mode. It clears after I cycle the ignition.
I can't test for it when static because it is fine. It only happens in a dynamic situation.

I have a suspicion that it may be a bad earth or a cable that is pulled when I turn the corners of a roundabout. Anybody had any similar faults??
Hi gjb02storm


Possible problem with the throttle position wiring connector in the passenger seat area. This connector is only found on RHD as its the actual TPS pick up on the LHD car.

Solution is to remove the connector and solder the wires together instead.

Have a look at This topic - code P1161

What fault code 'P' code number did you get for your faulty C3?
You can add an avatar to your account - Avatar or change your vehicle details - Car Bio or even add a signature to your posts - Signature. But this is not all you can do in the User Control Panel :)
  • Similar Topics
    Replies
    Views
    Last post