Injector circuit open HELP!

Questions specifically about a Petrol powered Citroen C3 (usually engine or fuel related problems).
Forum rules
One question per topic.
Petrol engine related faults, like injectors, error codes, overheating.
You can post more topics if necessary, but only one question per topic.
My Name: Slevan7

Contributor
Posts: 7
Joined: Mon May 08, 2017 9:16 pm
Model: C3 2002-2005, Original shape model
Year: 2003 (03)
Engine Size: 1.4 (8v)
Fuel Type: Petrol
Mileage: 80000
Trim Level: LX
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)

Post

I'm after some help
I recently had the cambelt break on my 2003 c3 1.4 so pulled the head off changed the bent valves new headgasket etc etc however it won't start cars saying injector circuit open an all four injectors which I believe is something I've done any idea what I might of done? It's all connected but I didn't disconnect the rail from the head when I did the work maybe I've knocked or something?
Also I'm getting a vehicle comm bus A fault? Could that be related.

Any help would be much appreciated.
User avatar
My Name: C3CAR

Guru
Posts: 2621
Joined: Wed May 04, 2011 10:01 am
Model: C3 2002-2005, Original shape model
Year: 2002 (02)
Engine Size: 1.4 (16v)
Fuel Type: Diesel
Mileage: 140000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: DV4 16-valve diesel (90 PS)
Has thanked: 148 times
Been thanked: 88 times

Post

Did you time the head up to the crank correctly?
Slevan7 wrote:Also I'm getting a vehicle comm bus A fault? Could that be related.
What code do you get for that ? the 'P' code?
My Name: Slevan7

Contributor
Posts: 7
Joined: Mon May 08, 2017 9:16 pm
Model: C3 2002-2005, Original shape model
Year: 2003 (03)
Engine Size: 1.4 (8v)
Fuel Type: Petrol
Mileage: 80000
Trim Level: LX
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)

Post

I think I did I locked the cam off with an 8mm pin and used the timing marks on the pulley to the block it turned over fine by hand but didn't start, I then moved the crack 180% thinking it might be out and again by hand to check before trying again still no luck.

The codes are
P0201
P0202
P0203
P0204
And comm bus a is u0028
User avatar
My Name: C3CAR

Guru
Posts: 2621
Joined: Wed May 04, 2011 10:01 am
Model: C3 2002-2005, Original shape model
Year: 2002 (02)
Engine Size: 1.4 (16v)
Fuel Type: Diesel
Mileage: 140000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: DV4 16-valve diesel (90 PS)
Has thanked: 148 times
Been thanked: 88 times

Post

Slevan7 wrote:I think I did I locked the cam off with an 8mm pin and used the timing marks on the pulley to the block it turned over fine by hand but didn't start, I then moved the crack 180% thinking it might be out and again by hand to check before trying again still no luck.
OK, thanks.
Slevan7 wrote:The codes are
P0201
P0202
P0203
P0204
And comm bus a is u0028
With all 4 injectors affected it could be a fuse supplying the engine bay area, seeing as there is a bus error too, it could be a fuse to the engine ECU that has blown.

Engine fuse box:
citroen-c3-tips/c3-2002-to-2006-engine- ... -t157.html
My Name: Slevan7

Contributor
Posts: 7
Joined: Mon May 08, 2017 9:16 pm
Model: C3 2002-2005, Original shape model
Year: 2003 (03)
Engine Size: 1.4 (8v)
Fuel Type: Petrol
Mileage: 80000
Trim Level: LX
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)

Post

I've checked all in the engine bay next to the battery and under the glove box, all okay.
If the timing was out would it throw up these codes?

Just thinking there was two white lines on the new belt but it wasn't going to line up with the marks on the crank and cam so I ignored them.
My Name: Slevan7

Contributor
Posts: 7
Joined: Mon May 08, 2017 9:16 pm
Model: C3 2002-2005, Original shape model
Year: 2003 (03)
Engine Size: 1.4 (8v)
Fuel Type: Petrol
Mileage: 80000
Trim Level: LX
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)

Post

Okay so tonight I removed the injector rail which I didn't before the o rings look past it in fact one was non existent, plus and I will say I brought this with a broken belt for my run around it has two different type of spark plugs in there,

When I pulled the plugs however there covered in fuel I think the timing might be wrong, if I have a timing mark on my crank would I still have a locking hole on the flywheel?
I'm still confused as to why the belt had timing marks that didn't match up with the cars timing marks.
User avatar
My Name: C3CAR

Guru
Posts: 2621
Joined: Wed May 04, 2011 10:01 am
Model: C3 2002-2005, Original shape model
Year: 2002 (02)
Engine Size: 1.4 (16v)
Fuel Type: Diesel
Mileage: 140000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: DV4 16-valve diesel (90 PS)
Has thanked: 148 times
Been thanked: 88 times

Post

Slevan7 wrote:I'm still confused as to why the belt had timing marks that didn't match up with the cars timing marks.
The belt doesn't time. Its the position of the crank and the position of the cam that needs to be perfect.
Slevan7 wrote:plus and I will say I brought this with a broken belt for my run around
So it may have never run. Maybe its got more than one fault on it, like some knackered injectors?
Slevan7 wrote: if I have a timing mark on my crank would I still have a locking hole on the flywheel?
Yes, there is a locking off point for the crank, but you didn't need it.
My Name: Slevan7

Contributor
Posts: 7
Joined: Mon May 08, 2017 9:16 pm
Model: C3 2002-2005, Original shape model
Year: 2003 (03)
Engine Size: 1.4 (8v)
Fuel Type: Petrol
Mileage: 80000
Trim Level: LX
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)

Post

Okay only just got round to this but I've popped new plugs in as a said before there were odd matching ones,
I've also cleaned the injectors and fitted all new o rings, but still nothing it does want to start but I can't work it out.

Any ideas what this comm bus a fault is? Might be causing the open circuit issue.

Also possible it's a few teeth out?
My Name: Slevan7

Contributor
Posts: 7
Joined: Mon May 08, 2017 9:16 pm
Model: C3 2002-2005, Original shape model
Year: 2003 (03)
Engine Size: 1.4 (8v)
Fuel Type: Petrol
Mileage: 80000
Trim Level: LX
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)

Post

I've just had a thought the battery was flat when I received it is it possible that could be at fault? I remember a Mercedes A class a few years ago that was doing some strange things until I changed it including not starting.
User avatar
My Name: Arfur Dent

Guru
Posts: 3308
Joined: Sat Jul 23, 2011 3:47 pm
Model: C3 2002-2005, Original shape model
Year: 2002 (52)
Engine Size: 1.4 (16v)
Fuel Type: Diesel
Mileage: 100000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: DV4 16-valve diesel (90 PS)
Has thanked: 259 times
Been thanked: 112 times

Post

Slevan7 wrote:I've just had a thought the battery was flat when I received it is it possible that could be at fault? I remember a Mercedes A class a few years ago that was doing some strange things until I changed it including not starting.
Knackered batteries do give all sorts of odd faults on the C3.
You can add an avatar to your account - Avatar or change your vehicle details - Car Bio or even add a signature to your posts - Signature. But this is not all you can do in the User Control Panel :)
  • Similar Topics
    Replies
    Views
    Last post