Oil level indicator after oil change

Questions specifically about a Diesel powered C3 (usually engine or fuel related problems)
Please provide as much description including adding photos directly to the topic or videos you have uploaded via youtube as possible.
Forum rules
One question per topic.
No Gearbox questions
Diesel engine related problems
Think: Diesel engine, diesel fuel system, diesel injectors and glow plugs
My Name: stuartadair

Member
Posts: 2
Joined: Fri Apr 18, 2014 7:21 pm
Model: C3 Pluriel - with or without roof
Year: 2006 (56)
Engine Size: 1.4
Fuel Type: Diesel
Mileage: 55000
Trim Level: VTR+
Gearbox: Manual 5 speed
DPF: No

Post

Hi

2006 Pluriel 1.4hdi. Just changed clutch and decided to do an oil change at the same time. Filled to the correct level on the dipstick but the dashboard indicator says low oil and the spanner light is on.

Where is the sensor located so I can check I've not knocked a wire off ? Is there any process I should have followed to reset the system after battery was disconnected ?

Stu
User avatar
My Name: C3driver52

Guru
Posts: 1937
Joined: Sat Apr 30, 2011 7:40 pm
Model: C3 2002-2005, Original shape model
Year: 2003 (03)
Engine Size: 1.4 i
Fuel Type: Petrol
Mileage: 79984
Trim Level: VTR+
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: TU3 (75 PS)
Has thanked: 110 times
Been thanked: 67 times

Post

Hi Stu
stuartadair wrote: the spanner light is on
C3 Service indicator reset procedure is here
stuartadair wrote: Where is the sensor located so I can check I've not knocked a wire off ?
oil level sensor
oil level sensor
18 is the oil level sensor

stuartadair wrote:Is there any process I should have followed to reset the system after battery was disconnected ?
No. This is the procedure for disconnecting and reconnecting the battery.
My Name: stuartadair

Member
Posts: 2
Joined: Fri Apr 18, 2014 7:21 pm
Model: C3 Pluriel - with or without roof
Year: 2006 (56)
Engine Size: 1.4
Fuel Type: Diesel
Mileage: 55000
Trim Level: VTR+
Gearbox: Manual 5 speed
DPF: No

Post

Thank you very much for the reply. I left the car overnight, went out to it today and its now working properly.

Given that its Easter and a time of miracles perhaps a blessing has passed over my car :-)
  • Similar Topics
    Replies
    Views
    Last post