C3 HDI eco mode & won't turn over

Questions specifically about a Diesel powered C3 (usually engine or fuel related problems)
Please provide as much description including adding photos directly to the topic or videos you have uploaded via youtube as possible.
Forum rules
One question per topic.
No Gearbox questions
Diesel engine related problems
Think: Diesel engine, diesel fuel system, diesel injectors and glow plugs
My Name: ASH

Contributor
Posts: 14
Joined: Sat Apr 14, 2012 10:11 pm

Post

Hi Guy's..

My mums C3 1.4 HDI won't turn over after being parked up. I've connected jump leads to another car (thinking it was a flat battery) & still no luck.

It also has the battery light flashing on the dash and shows eco mode..

I was wondering if anyone had any ideas???

I will plug it into my Lexia at the weekend but it's parked in the middle of nowhere so will have to tow it back first..

Many thanks in advance..

ASH
User avatar
My Name: Arfur Dent

Guru
Posts: 3423
Joined: Sat Jul 23, 2011 3:47 pm
Model: C3 2002-2005, Original shape model
Year: 2002 (52)
Engine Size: 1.4 (16v)
Fuel Type: Diesel
Mileage: 100000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: DV4 16-valve diesel (90 PS)
Has thanked: 311 times
Been thanked: 119 times

Post

Hi ASH,

eco mode is the timer to disable accessories if the 'ignition' has been left on without starting the engine.

If the car doesn't turn over, suspect battery - which you have done, but also the starter motor and its solenoid.

There is some information on the starter motor here https://citroenc3owners.com/citroen-c3-t ... -t762.html


Lexia can help with eco mode, but not the starter motor. If it is the starter motor, eco mode will clear itself when the engine starts :)
You can add an avatar to your account - Avatar or change your vehicle details - Car Bio or even add a signature to your posts - Signature. But this is not all you can do in the User Control Panel :)
My Name: ASH

Contributor
Posts: 14
Joined: Sat Apr 14, 2012 10:11 pm

Post

Well.. get this..

I went to it this morning & plugged my lexis into it, read the faults and it found nothing..

I then connected jump leads to it and it started (although it didn't last night)..

Anyway, I drove it back to work and it drove faultless.. I turned it off then and it started fine (straight away)..

I then got a new battery to connect and decided to do it mid afternoon and it wouldn't start (old battery)..

I then decided to put the new batter straight on and still won't turn over..

Ive plugged my lexia in to see if anything was showing up & nothing

Any ideas???? PLEASE (If you can make sense of what I'm trying to say.. lol)

Thanks in advance

ASH
My Name: alsie2

Experienced Member
Posts: 91
Joined: Sat Jun 15, 2013 10:14 am
Model: C3 2006-2009, Facelift model
Year: 2008 (08)
Engine Size: 1.4 i
Fuel Type: Petrol
Mileage: 37
Trim Level: Cachet
Gearbox: Manual 5 speed
DPF: No

Post

Make sure your battery earth to body connection is ok, loosen and retighten. Intermitent problems tend to be an earth prob.
Also check engine to body earth.
  • Similar Topics
    Replies
    Views
    Last post