1.4 HDi 8v Non Starter - P1351

Questions specifically about a Diesel powered C3 (usually engine or fuel related problems)
Please provide as much description including adding photos directly to the topic or videos you have uploaded via youtube as possible.
Forum rules
One question per topic.
No Gearbox questions
Diesel engine related problems
Think: Diesel engine, diesel fuel system, diesel injectors and glow plugs
My Name: rich_p55

Member
Posts: 1
Joined: Sat Mar 16, 2013 9:35 am

Post

Hi,

The car is a 04' 8v HDi, with 115,000 Miles on the clock.

Had problems starting the car last weekend: it turned over and started for about 2-3 seconds, then stalled. Turned over a few times without starting, then eventually came to life.

After a run of about 40 miles and stopping, it started again fine, but then the following day, the same thing happened.

Turned over and started for about 2-3 seconds, then stalled. Now it turns over, but won't start and is showing the Engine Auto Diagnostics warning light.

Plugging in a fault code reader gives code P1351 and on advice, we changed the Cam position sensor, but the code remains and it still won't start.

Any ideas what the problem could be and how to resolve?

Would prefer to avoid main dealer if possible...

Thanks.
User avatar
My Name: Arfur Dent

Guru
Posts: 3423
Joined: Sat Jul 23, 2011 3:47 pm
Model: C3 2002-2005, Original shape model
Year: 2002 (52)
Engine Size: 1.4 (16v)
Fuel Type: Diesel
Mileage: 100000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: DV4 16-valve diesel (90 PS)
Has thanked: 311 times
Been thanked: 119 times

Post

Hello rich_p55
Plugging in a fault code reader gives code P1351 and on advice, we changed the Cam position sensor, but the code remains and it still won't start.
On a diesel C3, 1.4, 16v - Delphi C6 ECU (which is similar in most respects, except a few to trip you up) Cam sensor fault could be P0341
P0341 cam sensor sync fault
P0341 cam sensor sync fault

I think P1351 on the diesel is a problem with the pre-heating glow plug relay or glow plugs, not a cam sensor problem.
'Permanent Fault: Pre-Heat Relay supplied but heater plugs never supplied' P1351 on a C3 HDi
I don't see a connection between P1351 and the cam. Further code reading will be required with a more comprehensive reading tool (like a Citroen Lexia (from here - Amazon)). With all that cutting out, there will be loads more codes stored you can read with lexia :)

But, don't let that get your hopes up as a glow plug relay or even the glow plugs themselves are not going to stop the car from starting or even running, I don't think P1351 is your problem at all.

If you don't want to go down the connecting a computer and reading all the codes route, well, with 115K miles, maybe the injectors are getting worn. A leak off test is a simple check for injectors. Worn injectors will stop the engine starting due to low fuel pressure, there will be codes stored for this in lexia
Would prefer to avoid main dealer if possible...
Citroen Lexia (from here) or try here on eBay.co.uk on a laptop running windows XP/7 to get all the codes is going to be your starting point, just as citroen would do, but without their charge. Then take it from there :)
You can add an avatar to your account - Avatar or change your vehicle details - Car Bio or even add a signature to your posts - Signature. But this is not all you can do in the User Control Panel :)
  • Similar Topics
    Replies
    Views
    Last post