Pluriel Roof ECU burnt out

If you need help with your C3 Pluriel, that seems specific to the Pluriel (like the roof), ask here. Engine and Transmission problem must be asked in the relevant topic for the problem. The Pluriel shares the same Engine, Gearbox, Brakes and Transmission as the other C3 models (see above for the correct section).
Forum rules
Questions about the Pluriel Roof system can be asked here
No engine, gearbox or running gear questions
Think: Pluriel roof and rear window jobs
Did you know the Pluriel shares the engines, gearboxes, electrical, audio system, suspension, steering and running gear with the early C3?
My Name: JHBonarius

Member
Posts: 1
Joined: Tue Sep 10, 2019 8:47 am
Model: C3 Pluriel - with or without roof
Year: 2005 (55)
Engine Size: 1.4
Fuel Type: Petrol
Mileage: 80000
Trim Level: NA
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: LHD (Europe)
Engine name: TU3 (75 PS)

Post

Hi all,

When trying to open the roof of my Jan 2006 Pluriel, I smelled something burning. After that the roof was dead.
Investigation showed that a component in my roof ECU had burned out!
20190909-211615.jpg
It looks like a power choke (inductor).

Does anybody know what that component is? Could anybody open up their roof ECU for me to take a picture of the marking on the component?
It's the model with the brown connector with markings:
TO A42 F3M3 CEM1.0
PSA 9654756180B
IRS 1000 6766A
11K5 A 004689
HW02.02 SW03.02 D

Yeah, I know, there's probably some short circuit somewhere else in the wiring, but I'm still working on that. In the mean time I would like to fix the ECU as soon as possible.
My Name: smac

Experienced Member
Posts: 42
Joined: Tue May 01, 2018 12:30 am
Model: C3 Pluriel - with or without roof
Year: 2009 (09)
Engine Size: 1.4
Fuel Type: Diesel
Mileage: 60000
Trim Level: NA
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: LHD (Europe)
Has thanked: 1 time
Been thanked: 12 times

Post

Not sure if our ECUs are the same, but I snapped a few pics of mine while I was in there.
Hope this helps :)
Attachments
IMG_20190916_131623.jpg
IMG_20190916_131624.jpg
IMG_20190916_131636.jpg
IMG_20190916_131722.jpg
User avatar
My Name: Ozvtr

Moderator
Posts: 941
Joined: Wed Jul 10, 2019 3:31 am
Model: C3 2002-2005, Original shape model
Year: 2003 (53)
Engine Size: 1.4 (8v)
Fuel Type: Petrol
Mileage: 80000
Trim Level: Other
Gearbox: Automatic PRND
DPF: No
LHD or RHD: RHD
Engine name: TU3 (75 PS)
Location: Brisbane, Australia.
Has thanked: 36 times
Been thanked: 251 times

Post

It's a WSR style 3 Watt current sensing resistor with a value of 0.017 ohms 1%. Dale part number 10711AA by the looks. I can't find one... :roll: !
0.015 Ohms seems to be a more common value and there are a few on ebay https://www.ebay.co.uk/itm/1X-VISHAY-WSR3R0150FEA- You could also try RS components and Mouser.
However it seems the auto cutoff or "anti pinch" circuitry is not working. I would say the roof has been stopped by something or stopped in either the fully open or closed position and the anti pinch function has failed, stalling the motor, resulting in the resistor burning out. Being part of the anti pinch circuit, it's possible the resistor carbonized and caused the the auto cut off to fail but that's just a guess. My gut tells me the resistor is a symptom not a cause.
Depends on the cost to replace the ECU as to whether you attempt to replace the resistor or not.
  • Similar Topics
    Replies
    Views
    Last post