2007 Pluriel boot (screen) won't open

If you need help with your C3 Pluriel, that seems specific to the Pluriel (like the roof), ask here. Engine and Transmission problem must be asked in the relevant topic for the problem. The Pluriel shares the same Engine, Gearbox, Brakes and Transmission as the other C3 models (see above for the correct section).
Forum rules
Questions about the Pluriel Roof system can be asked here
No engine, gearbox or running gear questions
Think: Pluriel roof and rear window jobs
Did you know the Pluriel shares the engines, gearboxes, electrical, audio system, suspension, steering and running gear with the early C3?
My Name: charly01

Contributor
Posts: 7
Joined: Tue Apr 26, 2016 5:53 am
Model: C3 Pluriel - with or without roof
Year: 2007 (07)
Engine Size: 1.4
Fuel Type: Petrol
Mileage: 54000
Trim Level: VTR+
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)

Post

Hi, I am new to this forum and have a very frustrating problem. Recently out of the blue the rear screen won't open. The central locking power noise is going through to the switch, when pressing the switch it will only open a few mms and then has to be pushed down again. I do not want to forcefully open it. I have spent many hours in researching this issue and the only posts I have read is that the roof and boot are related, this is strange because my roof opens all the way to the back boot. If you guys can give me a definitive answer it would be much appreciated. I want to avoid the stealership as much as possible! ;)

Looking forward to your replies! Must be a common problem for pluplu owners!

Thanks!
User avatar
My Name: C3CAR

Guru
Posts: 2621
Joined: Wed May 04, 2011 10:01 am
Model: C3 2002-2005, Original shape model
Year: 2002 (02)
Engine Size: 1.4 (16v)
Fuel Type: Diesel
Mileage: 140000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: DV4 16-valve diesel (90 PS)
Has thanked: 148 times
Been thanked: 88 times

Post

charly01 wrote:Hi, I am new to this forum and have a very frustrating problem. Recently out of the blue the rear screen won't open. The central locking power noise is going through to the switch, when pressing the switch it will only open a few mms and then has to be pushed down again. I do not want to forcefully open it. I have spent many hours in researching this issue and the only posts I have read is that the roof and boot are related, this is strange because my roof opens all the way to the back boot. If you guys can give me a definitive answer it would be much appreciated. I want to avoid the stealership as much as possible! ;)

Looking forward to your replies! Must be a common problem for pluplu owners!

Thanks!
Hello charly01

You should check the roof parts are not damaged or broken because as you say the roof and the rear window are connected.

If the roof is not operating absolutely correctly then you may be stopping the boot from opening. Look for alignment, damage and 'witness marks' of damage done by misaligned or worn parts.

Can you determine the reason the rear screen won't open fully? Is it jammed at one side or is it catching on something?

I don't think there are many cheap fixes to the pluriel roof :(
My Name: charly01

Contributor
Posts: 7
Joined: Tue Apr 26, 2016 5:53 am
Model: C3 Pluriel - with or without roof
Year: 2007 (07)
Engine Size: 1.4
Fuel Type: Petrol
Mileage: 54000
Trim Level: VTR+
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)

Post

Hi C3CAR,

Thank you for getting back to me. The roof does seem to be closed properly I believe so. It makes the locking click as it closes which it has always done so I'm guessing it's alignment is correct? I haven't tried the roof this evening as I am scared it won't close after I have opened it. Hopefully it will work ok, will try it when I don't need to use the car all day.

I fully cleaned the car yesterday and for some random reason the boot did actually open. However, after driving the car today it once again doesn't open. It seems to be jammed in the middle under the button? I don't know if this is possible, when I had a look at it yesterday, the locks seem to be on each side. I really am no expert as you can tell. Yesterday when it did open I greased the locks to ease them a bit. I really don't know what's going on.

Thanks!
My Name: charly01

Contributor
Posts: 7
Joined: Tue Apr 26, 2016 5:53 am
Model: C3 Pluriel - with or without roof
Year: 2007 (07)
Engine Size: 1.4
Fuel Type: Petrol
Mileage: 54000
Trim Level: VTR+
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)

Post

Can any c3 gurus help me? :cry:
  • Similar Topics
    Replies
    Views
    Last post