Wiper control

Questions not related to the fuel type, like Manual Gearbox, Body Work, Lights, Interior trim and Seats, Steering, Brakes, Beeping, Wheels and Tyres to be asked in this topic only.

Audio has its own section - see further down the page.

Please provide as much information as you think may be relevant like recent work on the car and you can attach photographs directly to your topic using the form below the text box.
Forum rules
One question per topic.
No Engine questions
Think: Manual Gearbox, Seats, Bodywork, Lighting, Interior, A/C, Heater, Wheels, Steering, Brakes, Tyres and Suspension
My Name: holloway1

Member
Posts: 2
Joined: Mon Feb 27, 2017 11:30 am
Model: C3 2002-2005, Original shape model
Year: 2002 (02)
Engine Size: 1.4
Fuel Type: Diesel
Mileage: 136000
Trim Level: LX
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)

Post

Hi,
I read some posts but I am not sure if it's the whole comms unit that I need or not, but just in case this is the problem.

When I select the wiper control, it works without stopping even when I try to stop it. Also it make a noise as if it's trying to use the washer for a while then stops, but the wiper doesn't stop. To stop the wiper, I have to stop the engine, do ignion on, then the wiper does one swipe and stops on its own.

Occasionally the wiper works ( starts and stops when required ) but this happens once in a while.

Also the rear wiper doesn't work.


So I am not sure if its the whole comms unit is needed, I heard that you need to take if off first then get the ref to match, but I can get them from partsgateway without it.


I use the car on a daily basis so I hope that it's minor and quick.
Thanks
My Name: holloway1

Member
Posts: 2
Joined: Mon Feb 27, 2017 11:30 am
Model: C3 2002-2005, Original shape model
Year: 2002 (02)
Engine Size: 1.4
Fuel Type: Diesel
Mileage: 136000
Trim Level: LX
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)

Post

my problem is that mine works, but doesn't stop.
User avatar
My Name: C3driver52

Guru
Posts: 1877
Joined: Sat Apr 30, 2011 7:40 pm
Model: C3 2002-2005, Original shape model
Year: 2003 (03)
Engine Size: 1.4 i
Fuel Type: Petrol
Mileage: 79984
Trim Level: VTR+
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: TU3 (75 PS)
Has thanked: 89 times
Been thanked: 66 times

Post

holloway1 wrote:Hi,
I read some posts but I am not sure if it's the whole comms unit that I need or not, but just in case this is the problem.
Hi holloway1

The COM2000 unit is know for giving these sort of faults. But without testing the input/output computer signals you will never know for sure until you diagnose it or just change it.

Your choice is to either diagnose it using a lexia tool like this or just change the COM2000 for a known working one.

If you are considering gown down the lexia route, read up on this topic before embarking on that journey :)
holloway1 wrote:So I am not sure if its the whole comms unit is needed, I heard that you need to take if off first then get the ref to match, but I can get them from partsgateway without it.
To be sure you are getting the same one, best to match it by part number, but it is possible to mix and match but you may need to update the BSI software or find the COM2000 won't work, there is no list of which COM goes on which model. You can also find the COM2000 units on eBay by clicking here.
  • Similar Topics
    Replies
    Views
    Last post