serv light / sidelight error and trim part and unknown part!

Questions not related to the fuel type, like Manual Gearbox, Body Work, Lights, Interior trim and Seats, Steering, Brakes, Beeping, Wheels and Tyres to be asked in this topic only.

Audio has its own section - see further down the page.

Please provide as much information as you think may be relevant like recent work on the car and you can attach photographs directly to your topic using the form below the text box.
Forum rules
One question per topic.
No Engine questions
Think: Manual Gearbox, Seats, Bodywork, Lighting, Interior, A/C, Heater, Wheels, Steering, Brakes, Tyres and Suspension
My Name: johnh

Contributor
Posts: 11
Joined: Fri Jun 13, 2014 6:34 pm
Model: C3 2006-2009, Facelift model
Year: 2006 (06)
Engine Size: 1.4 i
Fuel Type: Petrol
Mileage: 34000
Trim Level: Desire
Gearbox: Manual 5 speed
DPF: No

Post

Hi, I have recently bought a 2006 citroen c3 desire 1.4 petrol (lucky me!) , on the 2nd day of owning it I had the airbag / seatbelt, serv light and sidelamp errors appear, I managed to trace the airbag / seatbelt error to a bunch of wires under the glovebox, im sure that there is a sealbelt/airbag sensor there, as well as under the passenger seat, anyways it was supposed to be held in location by a plastic clip under the glovebox but was hanging down and possibly disturbed when using the bonnet release, so I clipped it back up and voila...airbag and seatbeltx2 lights disappeared from the dash display. However the serv light on the dash and sidelamp error on the digital console display still appear for around 5 mins after start up and then randomly when driving (usually on motorway when driving at speed).

My questions are.... how do I get sort out the serv light and sidelamp error?
Is there supposed to be a plastic cover that keeps the cables in place under the glovebox that maybe has a cut out for the bonnet release?? It does look like there is a cover missing but I don't know what the part is called to enable to source one lol

One last thing, I promise!!! ....The car was making a whirring noise from the nsr wheel area and I traced this to the nsf plastic wheelarch liner, its hanging down and damaged, I managed to do a temp fix with the trusty cable ties but when fixing it back in place I noticed some sort of a module under the engine with 2 ports which look like usb type things but bigger, this obviously was exposed due to the missing piece of wheel arch liner, does anyone know what this may be, it looks like an ecu type part?? Maybe water splashing from the road onto this may cause the sidelamp fault??

Sorry for this post being so long winded and I would be grateful for any advice.

thanks
User avatar
My Name: ko3st

Member
Posts: 4
Joined: Sat May 17, 2014 12:02 pm
Model: C3 2013-2017 Facelift A51
Year: 2014 (14)
Engine Size: I dont know
Fuel Type: Petrol
Mileage: 300
Gearbox: Manual 5 speed
DPF: No
Been thanked: 1 time

Post

Perhaps you can make a picture, it would help clearing things up.
User avatar
My Name: C3driver52

Guru
Posts: 1943
Joined: Sat Apr 30, 2011 7:40 pm
Model: C3 2002-2005, Original shape model
Year: 2003 (03)
Engine Size: 1.4 i
Fuel Type: Petrol
Mileage: 79984
Trim Level: VTR+
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: TU3 (75 PS)
Has thanked: 116 times
Been thanked: 68 times

Post

johnh wrote:My questions are.... how do I get sort out the serv light and sidelamp error?
Sidelamp error could be this?

I don't know about the service light, I assume its the MIL (picture of an engine in orange outline?) - could be errors stored - check with lexia or OBD
johnh wrote:Is there supposed to be a plastic cover that keeps the cables in place under the glovebox that maybe has a cut out for the bonnet release?? It does look like there is a cover missing but I don't know what the part is called to enable to source one lol
No, I don't think there are any extra covers under the BSI, maybe this picture will help?


Citroen C3 2006 BSI hidden fuse box
Citroen C3 2006 BSI hidden fuse box
Citroen_C3_2006_BSI_hidden_cabin_fuse_box_location_674.jpg (20.97 KiB) Viewed 107 times
My Name: johnh

Contributor
Posts: 11
Joined: Fri Jun 13, 2014 6:34 pm
Model: C3 2006-2009, Facelift model
Year: 2006 (06)
Engine Size: 1.4 i
Fuel Type: Petrol
Mileage: 34000
Trim Level: Desire
Gearbox: Manual 5 speed
DPF: No

Post

Thanks very much "GURU" at least I now know that my car isn't missing a cover!
I actually sorted the seatbelt and airbag error yesterday, just by chance I noticed that there was a bunch of wires hanging down near the bonnet release handle, im pretty sure that these were being disturbed when opening the bonnet, the connector blocks are supposed to be secured on slide type clips under the glovebox, however someone previously had pulled the clips out and put them back in the wrong way, hence dangling wires! One of them was the same as under the passenger seat (little grey coloured connector) im sure its an airbag sensor.
However I still have the "serv" icon still illuminates at times and at the same time the onboard computer displays "side lamp error" Its the 3rd light I think on the bottom of dashboard, I think that you was explaining the engine management light, which is a picture on an engine, it isn't that one.
The sidelamps look pretty new with no mirroring or smokey colour and they work just fine?!
Would the rear light cluster connector effect the front sidelights??
Weirdly now though I only seem to get the beep and error when hitting or exceeding 70 mph on motorway!
The alternator is also now whining that much it sounds as if my car is supercharged and it gets very hot , so its back to the car salesman on sat to get a new alternator, maybe the sidelamp error is part of the alternator problem? Only time will tell :)
My Name: smokescreen

Contributor
Posts: 13
Joined: Sun Feb 03, 2013 3:45 pm
Model: C3 2006-2009, Facelift model
Year: 2006 (06)
Engine Size: 1.6 (16v)
Fuel Type: Diesel
Mileage: 202000
Gearbox: Manual 5 speed
DPF: Yes
LHD or RHD: RHD (UK)
Engine name: DV6 16-valve diesel DPF-FAP (110 PS)
Been thanked: 2 times

Post

This may not be the answer but when I had a sidelight bulb warning I was bamboozled as both front sidelights and rear taillights were OK. Eventually I noticed that both number plate lights bulbs had blown, worth a look if you haven't already.
User avatar
My Name: C3CAR

Guru
Posts: 2708
Joined: Wed May 04, 2011 10:01 am
Model: C3 2002-2005, Original shape model
Year: 2002 (02)
Engine Size: 1.4 (16v)
Fuel Type: Diesel
Mileage: 140000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: DV4 16-valve diesel (90 PS)
Has thanked: 186 times
Been thanked: 103 times

Post

ko3st wrote:Perhaps you can make a picture, it would help clearing things up.
johnh wrote:I noticed some sort of a module under the engine with 2 ports which look like usb type things but bigger,
Any luck with taking a photo of the unknown part?
My Name: starfield

Contributor
Posts: 9
Joined: Tue Oct 15, 2019 8:02 pm
Model: C3 2006-2009, Facelift model
Year: 2008 (08)
Engine Size: 1.4 (16v)
Fuel Type: Petrol
Mileage: 54184
Trim Level: Cool Summer
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Has thanked: 1 time

Post

Did you manage to resolve the SERV light issue. If so how?
I am having the exact same problem.
  • Similar Topics
    Replies
    Views
    Last post