Picasso washer pump not working

Questions not related to the fuel type, like Manual Gearbox, Body Work, Lights, Interior trim and Seats, Steering, Brakes, Beeping, Wheels and Tyres to be asked in this topic only.

Audio has its own section - see further down the page.

Please provide as much information as you think may be relevant like recent work on the car and you can attach photographs directly to your topic using the form below the text box.
Forum rules
One question per topic.
No Engine questions
Think: Manual Gearbox, Seats, Bodywork, Lighting, Interior, A/C, Heater, Wheels, Steering, Brakes, Tyres and Suspension
My Name: wetone1738

Member
Posts: 3
Joined: Wed Jun 01, 2022 5:27 pm
Model: C3 Picasso
Year: 2016 (66)
Engine Size: 1.6
Fuel Type: Diesel
Mileage: 53500
Trim Level: Other
Gearbox: Manual 5 speed
DPF: Yes
LHD or RHD: RHD (UK)
Engine name: BlueHDi (75 PS)

Post

Hi, I have a 2016 C3 Picasso, recently the windscreen washer has stopped working, the result seemed to be the pump was not working (no sound when activated), so I have replaced the pump but still it does not work, fuses are ok, water tank is full (no leaks) so I am stuck as to what the issue is? Any guidance would be much appreciated.
Thank you.
Steve
User avatar
My Name: Ozvtr

Moderator
Posts: 1043
Joined: Wed Jul 10, 2019 3:31 am
Model: C3 2002-2005, Original shape model
Year: 2003 (53)
Engine Size: 1.4 (8v)
Fuel Type: Petrol
Mileage: 80000
Trim Level: Other
Gearbox: Automatic PRND
DPF: No
LHD or RHD: RHD
Engine name: TU3 (75 PS)
Location: Brisbane, Australia.
Has thanked: 44 times
Been thanked: 300 times

Post

The two next likely suspects would be the switch stalk behind the steering wheel or the relay in the BSM (the engine bay fuse box).
Does the rear washer work?
My Name: wetone1738

Member
Posts: 3
Joined: Wed Jun 01, 2022 5:27 pm
Model: C3 Picasso
Year: 2016 (66)
Engine Size: 1.6
Fuel Type: Diesel
Mileage: 53500
Trim Level: Other
Gearbox: Manual 5 speed
DPF: Yes
LHD or RHD: RHD (UK)
Engine name: BlueHDi (75 PS)

Post

Hi, thanks for info, the new pump is not making any noise, have checked the 10a fuse but will check again, no water front or back, just wondered if the feed pipes could be an issue as in must they be on a particular nipple?

Thanks

Steve
User avatar
My Name: Ozvtr

Moderator
Posts: 1043
Joined: Wed Jul 10, 2019 3:31 am
Model: C3 2002-2005, Original shape model
Year: 2003 (53)
Engine Size: 1.4 (8v)
Fuel Type: Petrol
Mileage: 80000
Trim Level: Other
Gearbox: Automatic PRND
DPF: No
LHD or RHD: RHD
Engine name: TU3 (75 PS)
Location: Brisbane, Australia.
Has thanked: 44 times
Been thanked: 300 times

Post

If the washer motor is not running it wont matter if you have the pipes around the wrong way.
I don't have a circuit diagram for the later model Picasso so I'm flying blind so to speak.
The motor runs "forwards" to wash the front wind screen and "backwards" to wash the rear.
There are two relays in the engine bay fuse box that determine which way the pump runs. Its unlikely that both relays have gone. Seeing as it wont wash either 'screen.
So the next most likely scenario is loss of power to the relays or wiring from the fuse box to the pump.
Have you pulled the fuse out and inspected the contacts in the engine bay fuse box? Look for corrosion, discoloured contacts where the fuse plugs in, etc. Typically the pump corrodes and the impeller wont move. This causes excessive current draw which blows the fuse. However sometimes it might cause damage to the wiring, electrical connectors or tracks of the printed circuit of the fuse box.
You could also try removing the electrical connectors at the engine bay fuse box and look for corrosion or melted connections in the plugs and sockets.
Lastly, see if you can hear the relays clicking in the engine bay fuse box when you select the washer. If you cant, that might indicate a problem with the switch stalk.
My Name: wetone1738

Member
Posts: 3
Joined: Wed Jun 01, 2022 5:27 pm
Model: C3 Picasso
Year: 2016 (66)
Engine Size: 1.6
Fuel Type: Diesel
Mileage: 53500
Trim Level: Other
Gearbox: Manual 5 speed
DPF: Yes
LHD or RHD: RHD (UK)
Engine name: BlueHDi (75 PS)

Post

Hi, thanks for the info., I will take a look at the fuses again, but saying that the washers have worked ok until a few weeks ago?
  • Similar Topics
    Replies
    Views
    Last post