Multiple dashboard waring lights.

Questions not related to the fuel type, like Manual Gearbox, Body Work, Lights, Interior trim and Seats, Steering, Brakes, Beeping, Wheels and Tyres to be asked in this topic only.

Audio has its own section - see further down the page.

Please provide as much information as you think may be relevant like recent work on the car and you can attach photographs directly to your topic using the form below the text box.
Forum rules
One question per topic.
No Engine questions
Think: Manual Gearbox, Seats, Bodywork, Lighting, Interior, A/C, Heater, Wheels, Steering, Brakes, Tyres and Suspension
My Name: Stuart9

Contributor
Posts: 7
Joined: Thu Mar 11, 2021 2:42 pm
Model: C3 2009-2013, New shape (A51)
Year: 2010 (10)
Engine Size: 1.6
Fuel Type: Diesel
Mileage: 80000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: Yes
LHD or RHD: RHD (UK)
Has thanked: 1 time

Post

Hey guys
I am hoping somebody can help me I have a citroen c3 2010 exclusive 1.6 hdi. My problems started about two three weeks ago got into the car went to start car and my wipers were going crazy headlights on and car would not start with alot of warnings coming up on dash such as braking faulty, airbags faulty, anti theft faulty and seatbelts faulty. Following this I decided to send the ecu off for testing and has come back no fault I have also checked fuses and I am now absolutely lost
User avatar
My Name: Arfur Dent

Guru
Posts: 3303
Joined: Sat Jul 23, 2011 4:47 pm
Model: C3 2002-2005, Original shape model
Year: 2002 (52)
Engine Size: 1.4 (16v)
Fuel Type: Diesel
Mileage: 100000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: DV4 16-valve diesel (90 PS)
Has thanked: 258 times
Been thanked: 111 times

Post

Stuart9 wrote: Thu Mar 11, 2021 2:46 pm Hey guys
I am hoping somebody can help me I have a citroen c3 2010 exclusive 1.6 hdi. My problems started about two three weeks ago got into the car went to start car and my wipers were going crazy headlights on and car would not start with alot of warnings coming up on dash such as braking faulty, airbags faulty, anti theft faulty and seatbelts faulty. Following this I decided to send the ecu off for testing and has come back no fault I have also checked fuses and I am now absolutely lost
Hi

This doesn't sound like the ECU at fault, don't send that off.

It also doesn't sound like is BSI fault, don't send that off.

What it does sound like is a poor voltage to the computers, something like a failing battery would give.

Engine didn't start - Did it turn over?
You can add an avatar to your account - Avatar or change your vehicle details - Car Bio or even add a signature to your posts - Signature. But this is not all you can do in the User Control Panel :)
My Name: Stuart9

Contributor
Posts: 7
Joined: Thu Mar 11, 2021 2:42 pm
Model: C3 2009-2013, New shape (A51)
Year: 2010 (10)
Engine Size: 1.6
Fuel Type: Diesel
Mileage: 80000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: Yes
LHD or RHD: RHD (UK)
Has thanked: 1 time

Post

No didn't crank over all I hear is a click coming from fusebox I have ordered a new battery now got old one checked and come up as replace
My Name: Stuart9

Contributor
Posts: 7
Joined: Thu Mar 11, 2021 2:42 pm
Model: C3 2009-2013, New shape (A51)
Year: 2010 (10)
Engine Size: 1.6
Fuel Type: Diesel
Mileage: 80000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: Yes
LHD or RHD: RHD (UK)
Has thanked: 1 time

Post

Changed battery no joy still same problem 😕
User avatar
My Name: C3driver52

Guru
Posts: 1854
Joined: Sat Apr 30, 2011 8:40 pm
Model: C3 2002-2005, Original shape model
Year: 2003 (03)
Engine Size: 1.4 i
Fuel Type: Petrol
Mileage: 79984
Trim Level: VTR+
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: TU3 (75 PS)
Has thanked: 85 times
Been thanked: 65 times

Post

Stuart9 wrote: Thu Mar 11, 2021 5:15 pm No didn't crank over all I hear is a click coming from fusebox I have ordered a new battery now got old one checked and come up as replace
No click,click,click,click of the solenoid on the starter motor?

No solenoid and no starter can be a very bad battery,
Stuart9 wrote: Fri Mar 12, 2021 3:14 pm Changed battery no joy still same problem 😕
OK, so the battery is ok.

But it won't turn over, not even click, click, click the solenoid

Bad earth from the battery
Bad starter
Bad ignition switch
Blown starter fuse (linked to bad starter) - F8 20A in the engine bay (probably)


Do you still get the erroneous warning lights on the dashboard?
My Name: Stuart9

Contributor
Posts: 7
Joined: Thu Mar 11, 2021 2:42 pm
Model: C3 2009-2013, New shape (A51)
Year: 2010 (10)
Engine Size: 1.6
Fuel Type: Diesel
Mileage: 80000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: Yes
LHD or RHD: RHD (UK)
Has thanked: 1 time

Post

No click from starter checked battery earth. And checked fuses but will check them again. Makes me wonder if problem with fusebox hopefully not. Ony thing not check is starter
My Name: Stuart9

Contributor
Posts: 7
Joined: Thu Mar 11, 2021 2:42 pm
Model: C3 2009-2013, New shape (A51)
Year: 2010 (10)
Engine Size: 1.6
Fuel Type: Diesel
Mileage: 80000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: Yes
LHD or RHD: RHD (UK)
Has thanked: 1 time

Post

And has now gone into economy mode with a new battery
User avatar
My Name: Ozvtr

Moderator
Posts: 936
Joined: Wed Jul 10, 2019 4:31 am
Model: C3 2002-2005, Original shape model
Year: 2003 (53)
Engine Size: 1.4 (8v)
Fuel Type: Petrol
Mileage: 80000
Trim Level: Other
Gearbox: Automatic PRND
DPF: No
LHD or RHD: RHD
Engine name: TU3 (75 PS)
Location: Brisbane, Australia.
Has thanked: 36 times
Been thanked: 250 times

Post

I don't have a circuit diagram for the modern C3's but on the older cars the starter solenoid for manual cars ran straight from the ignition switch.
From maxi fuse #7 to the key then (basically) straight to the starter solenoid. The connection did go through the BSM but straight through. No relays or whatever.

The auto's and sensodrive cars had an interlock relay that sits just above the ABS ECU in the near side wing.

Again, not familiar with later model C3's, do you need to push on the brake or clutch to start the car? If not, then there is no interlock and the BSI and/or BSM are not involved.

You say you checked the battery earth do you mean the cable from the battery to the chassis and from the chassis to the gearbox?

Maxi fuse #7 powered everything connected to the ignition switch. So if you turn the switch and something happens then maxi fuse #7 is OK. If modern cars run the same system.
User avatar
My Name: Ozvtr

Moderator
Posts: 936
Joined: Wed Jul 10, 2019 4:31 am
Model: C3 2002-2005, Original shape model
Year: 2003 (53)
Engine Size: 1.4 (8v)
Fuel Type: Petrol
Mileage: 80000
Trim Level: Other
Gearbox: Automatic PRND
DPF: No
LHD or RHD: RHD
Engine name: TU3 (75 PS)
Location: Brisbane, Australia.
Has thanked: 36 times
Been thanked: 250 times

Post

Stuart9 wrote: Sat Mar 13, 2021 10:43 am And has now gone into economy mode with a new battery
Any car will remain in economy mode until the engine runs.

Yes, I know...catch 22.
User avatar
My Name: Ozvtr

Moderator
Posts: 936
Joined: Wed Jul 10, 2019 4:31 am
Model: C3 2002-2005, Original shape model
Year: 2003 (53)
Engine Size: 1.4 (8v)
Fuel Type: Petrol
Mileage: 80000
Trim Level: Other
Gearbox: Automatic PRND
DPF: No
LHD or RHD: RHD
Engine name: TU3 (75 PS)
Location: Brisbane, Australia.
Has thanked: 36 times
Been thanked: 250 times

Post

I think all the problems are related to a single fundamental problem.

Check the earths as I said.

Check the cable that goes from the battery to the stud inside the fuse box in the engine bay. Check that the cable is firm under the nut and there is no corrosion.
  • Similar Topics
    Replies
    Views
    Last post