Front wipers doesn't work on 1 and 2 speeds (only at MAX)

Questions not related to the fuel type, like Manual Gearbox, Body Work, Lights, Interior trim and Seats, Steering, Brakes, Beeping, Wheels and Tyres to be asked in this topic only.

Audio has its own section - see further down the page.

Please provide as much information as you think may be relevant like recent work on the car and you can attach photographs directly to your topic using the form below the text box.
Forum rules
One question per topic.
No Engine questions
Think: Manual Gearbox, Seats, Bodywork, Lighting, Interior, A/C, Heater, Wheels, Steering, Brakes, Tyres and Suspension
My Name: tomasa

Top Contributor
Posts: 39
Joined: Sat Aug 31, 2013 9:32 pm
Model: C3 2002-2005, Original shape model
Year: 2003 (03)
Engine Size: 1.4 (8v)
Fuel Type: Diesel
Mileage: 120000
Trim Level: VTR+
Gearbox: Manual 5 speed
DPF: Yes

Post

yes, i had Haynes manual for my fiat -it was awesome! ANyways im downloading 27 gigs of citroen technical documentation, maybe it will help.
I dont want to believe that i will have to change BSI...there is no new ones and it's stupid to put the old one... :(
My Name: tomasa

Top Contributor
Posts: 39
Joined: Sat Aug 31, 2013 9:32 pm
Model: C3 2002-2005, Original shape model
Year: 2003 (03)
Engine Size: 1.4 (8v)
Fuel Type: Diesel
Mileage: 120000
Trim Level: VTR+
Gearbox: Manual 5 speed
DPF: Yes

Post

Well, for people who will be in situation like me-who will search for answer how god damn fix wipers, i will share my story.

Today i had chance to take off wipers and get connectors to wiper's motor to see if there any voltage goes to it.
I connected tester to ground (green/yellow wire) and another to first connector's hole from RIGHT (the apposite side from ground wire).
There where was voltage..on max speed... i then put tester to second wire-it was dead. (if i remember good)..

i also was installing keyless locking system, i burned like 4 fuses in that time :D (i think this may had some impact cause once i opened rear door and the rear wiper switched ON once by itself!) i done like 4 BSI soft resets (battery change procedure was done)..
At the end of day i connected tester to the wires again-and guess what, they all worked! i got voltage on all positions! Then i was happy that BSI was fine and probably fault was in motor.
Then i attached wipers to motor -and it worked! I literally did nothing to fix it, just sprayed some WD40..and now it works just fine!
Oh by the way, after all this somehow fixed itself i started to hear relay noise when i turn on wiper switch, which wasn't there before, so i think maybe the problem was in stupid BSI software.

So if you will have problem like me-try to reset BSI. try t take off connector to motor and clean contacts, try to move wipers with your hands, slide up.
SO this is my lucky story. I hope it will continue working :)
If someone don't know what is battery change procedure wrote: Switch off the ignition and remove the key and any DIAG equipment.

Wait a full 3 minutes before disconnecting the battery.

The BSi must be allowed to go to SLEEP ie into "power save mode". Do not operate any equipment on the vehicle during this time. Remember, even opening the bonnet will wake the BSi on a vehicle fitted with alarm.

If the battery is under the bonnet, open the bonnet first and leave it up. 807 batteries can be dis-connected through the drivers window, remove floor cover first.

ALWAYS disconnect any DIAG equipment and do not operate any plips from other vehicles during the 3 minute waiting period.

PROCEDURE FOR BATTERY RECONNECTION

Unless otherwise instructed by Peugeot or Product Service, you must always carry out the following procedure, often referred to as a "soft re-boot", to minimise the possibility of the BSi corrupting its own software when reconnecting the vehicles battery supply.
Ensure the procedure for battery disconnection has been adhered to and importantly all BSi functions were switched off with the drivers window left down.

1 Close all doors
2 Remove ignition key if left in ignition
3 Reconnect battery. DO NOT open any doors
4 Wait 10 seconds
5 Switch on healights through the drivers window (you will hear a "bong")
6 Switch on ignition then start the vehicle and check system functions
  • Similar Topics
    Replies
    Views
    Last post