aircon not working

Questions not related to the fuel type, like Manual Gearbox, Body Work, Lights, Interior trim and Seats, Steering, Brakes, Beeping, Wheels and Tyres to be asked in this topic only.

Audio has its own section - see further down the page.

Please provide as much information as you think may be relevant like recent work on the car and you can attach photographs directly to your topic using the form below the text box.
Forum rules
One question per topic.
No Engine questions
Think: Manual Gearbox, Seats, Bodywork, Lighting, Interior, A/C, Heater, Wheels, Steering, Brakes, Tyres and Suspension
My Name: jayjay

Contributor
Posts: 12
Joined: Tue Jul 16, 2013 1:19 pm
Been thanked: 1 time

Post

Hi everyone,
This is my first post and I'm looking for some advice.
I've a 52 plate executive. Diesel, with a 1.4 16 valve engine.

It's seen two aircon guys. And they're both puzzled.

The engine starts from cold say, with one bar on the temp gauge.
I select aircon, and it kicks in. But after about 30 seconds, the fan doesn't kick in, I hear 3 beeps, the temperature gauge jumps to three bars and the aircon disengages.


The first guy filed it with gas and said it wasnt leaking gas. He then let a load of gas out as he may of overfilled it. He believed the pump was losing a positive after a short time.

The second guy said it was low on gas, the fan was getting power. But maybe a fan fault or maybe temp sensor issue.

There's no fault codes found on there equipment.

I won't be able to fix it myself, but a steer from you guys may help me get an understanding of what I need to get done.
I've read some posts and reset the bsi to no avail.
Many thanks
User avatar
My Name: Arfur Dent

Guru
Posts: 3433
Joined: Sat Jul 23, 2011 3:47 pm
Model: C3 2002-2005, Original shape model
Year: 2002 (52)
Engine Size: 1.4 (16v)
Fuel Type: Diesel
Mileage: 100000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: DV4 16-valve diesel (90 PS)
Has thanked: 319 times
Been thanked: 121 times

Post

Hi jayjay, welcome to the forum.
The engine starts from cold say, with one bar on the temp gauge.
I select aircon, and it kicks in. But after about 30 seconds, the fan doesn't kick in, I hear 3 beeps, the temperature gauge jumps to three bars and the aircon disengages.
From what you have said, my thoughts are that there is noting wrong with the air con. The air con is disengaging because the car computer has detected a problem elsewhere, quite possibly in the engine cooling, maybe the fan for the radiator.

The car is quite clever, if a problem with engine cooling is detected, its quite possible for the car to disengage unnecessary loads like 'air conditioning' to help protect the engine.

This could be why 2 air con guys are stumped, because its not an A/C problem. I would investigate the radiator engine cooling fan, the coolant level, temperature sensor and the thermostat. A Citroen Lexia diagnostic tool can test the engine cooling fan, and so can a Citroen dealer. Three beeps and that fault will generate at least one code, I am sure. The lexia too or a citroen dealer can read these. Your 52 plate diesel can't be read by most code readers :cry:
You can add an avatar to your account - Avatar or change your vehicle details - Car Bio or even add a signature to your posts - Signature. But this is not all you can do in the User Control Panel :)
My Name: jayjay

Contributor
Posts: 12
Joined: Tue Jul 16, 2013 1:19 pm
Been thanked: 1 time

Post

Hi, and thanks.
can you tell me if the fan is not working is that an issue with driving the car. I've had it for over a month now and have been sat stationary in heavy traffic during hot weather.but I got zero indications of overheating engine wise. But I'm unsure if the fan was kicking in.

I need to get a key programmed so I'll get the dealership to run a diagnostics whilst I'm there.
User avatar
My Name: Arfur Dent

Guru
Posts: 3433
Joined: Sat Jul 23, 2011 3:47 pm
Model: C3 2002-2005, Original shape model
Year: 2002 (52)
Engine Size: 1.4 (16v)
Fuel Type: Diesel
Mileage: 100000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: DV4 16-valve diesel (90 PS)
Has thanked: 319 times
Been thanked: 121 times

Post

can you tell me if the fan is not working is that an issue with driving the car.
Well, if the fan doesn't run then the engine may overheat, but this doesn't seem to have happened with all that sitting in traffic, but there is a feedback loop from the fan to the engine computer. So if the fan runs, but the feedback is broken, the car won't overheat, but it may disengage the A/C because the computer thinks the fan isn't running.

I need to get a key programmed so I'll get the dealership to run a diagnostics whilst I'm there.
You may just want to ask for a quote for the cost before you agree to anything at the dealership :o

Those pesky keys can be an embarrassment :oops:
You can add an avatar to your account - Avatar or change your vehicle details - Car Bio or even add a signature to your posts - Signature. But this is not all you can do in the User Control Panel :)
My Name: jayjay

Contributor
Posts: 12
Joined: Tue Jul 16, 2013 1:19 pm
Been thanked: 1 time

Post

Hi and thanks for getting back to me.Yeah I know the prices are expensive but now all I gotta do is get it programmed.

Anyway,maybe unconnected but I thought I'd add.I think my temp gauge is not working correctly.
Basically,when I turn the key 1 notch,I only get the first three temp lights illuminate. All other dash lights come on.
Then I start the car from cold and I get the first temp light illuminate as you would expect. This is when the aircon works. But after 30 seconds, I get three beeps,the aircon dies and those first three temp lights illuminate. I can then drive the car with no issues. But I only see those first three temp lights.yesterday I left the engine running after a long drive for minimum 20 minutes if not more.the fan didn't kick in. The temp gauge didn't rise past 3 lights. I could see no visible signs of cooking. What dya reckon?
My Name: jayjay

Contributor
Posts: 12
Joined: Tue Jul 16, 2013 1:19 pm
Been thanked: 1 time

Post

And it was obviously sweltering hot yesterday.
Thanks
User avatar
My Name: Arfur Dent

Guru
Posts: 3433
Joined: Sat Jul 23, 2011 3:47 pm
Model: C3 2002-2005, Original shape model
Year: 2002 (52)
Engine Size: 1.4 (16v)
Fuel Type: Diesel
Mileage: 100000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: DV4 16-valve diesel (90 PS)
Has thanked: 319 times
Been thanked: 121 times

Post

jayjay wrote:Anyway,maybe unconnected but I thought I'd add.I think my temp gauge is not working correctly.
Quite possibly connected, the ECU gets its information from the same sensor as the temperature gauge on most models, so it could be getting erroneous information and shutting down the air conditioning as a precaution.

Try Euro Car Parts or eBay can be good for little parts like the sensor.
You can add an avatar to your account - Avatar or change your vehicle details - Car Bio or even add a signature to your posts - Signature. But this is not all you can do in the User Control Panel :)
My Name: Hans Zarkov

Top Contributor
Posts: 38
Joined: Fri Nov 25, 2011 9:59 am
Model: C3 2002-2005, Original shape model
Year: 2004 (04)
Engine Size: 1.4 (16v)
Fuel Type: Diesel
Mileage: 120000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: No

Post

Hi JayJay,

try taking the car to kwikfit, they use a full discharge /recharge station. If it doesn't drop the temperature by 10% or doesn't work, then they will give you a full refund :)

John
  • Similar Topics
    Replies
    Views
    Last post