A51 Intermittently working front Wipers. Help!

Questions not related to the fuel type, like Manual Gearbox, Body Work, Lights, Interior trim and Seats, Steering, Brakes, Beeping, Wheels and Tyres to be asked in this topic only.

Audio has its own section - see further down the page.

Please provide as much information as you think may be relevant like recent work on the car and you can attach photographs directly to your topic using the form below the text box.
Forum rules
One question per topic.
No Engine questions
Think: Manual Gearbox, Seats, Bodywork, Lighting, Interior, A/C, Heater, Wheels, Steering, Brakes, Tyres and Suspension
My Name: doeboy

Member
Posts: 3
Joined: Sat Aug 03, 2013 11:02 am
Model: C3 2009-2013, New shape (A51)
Year: 2011 (11)
Engine Size: 1.6
Fuel Type: Diesel
Mileage: 80800
Trim Level: Exclusive
Gearbox: Manual 6 speed
DPF: No
LHD or RHD: RHD (UK)

Post

I've had an issue with the front wipers for around 6 months now. When I activate them by and large they work. I've had 5 occasions now when I've got in the car on a rainy day and turned them on and nothing. Then 2-6 minutes later when I try again they work. 3 weeks ago when we had some seriously heavy rain they wouldn't turn off. At first they turned off with the ignition off, then they kept going even when the engine was off. I had it taken to a Citroen independent who said basically the battery was knackered which seemed feasible after 5 years so he changed it and all seemed well for 3 weeks.

So 3 days ago I get in the car and it's raining and I turn them on. -Nothing- so I think ok I'll drive like before and they'll turn on in a few mins. It didn't I drove for 5 hours over 2 days without them working, by far the longest period so far that I thought they were truly dead. So I took it back to the independent who did some diagnostics but said he didn't have all the kit for the A51 so he took it to a stealer. They said it was the wiper motor, now wait for it... all in £380 So I'm put in a position by this chap on the phone at 16:25 he's got to get it ordered within 5 mins and I want it done by tomorrow he reminds me so reluctantly I give him the go ahead. After I get off the phone I think about it and find one instantly on eBay for £95 from a breakers. So I call him back the following morning at 9am and he lays it on thick... "You can't cancel, it's a special order!" Then I start getting how he's done me a favour taking it there and that I've damaged his reputation blah blah. 3-4 times he said this crap. So bottom line I ordered the £95 breakers part to his workshop for tomorrow Friday the 1st July and he manages to "pull some strings" again, how lucky I am and cancel the £290 part but for a 10% restocking fee. So I go to pick my car up where he relieves me of £88 for his time and the restocking fee and all of a sudden they're fully booked for at least 4 days! So on my way home the wipers start working again. Now tell me how this is a motor? So now I have a part arriving at this specialist garage tomorrow that I suspect I didn't need to order in the first place and I'm supposed to take to my usual garage to fit.

I'm at a total loss here. All I can think of is it was raining the whole time they failed and then we had 14+ dry hours and they started working again. And are the two issues related? not turning off then not turning on? and If these guys can't accurately diagnose it with the right tools then what chance do I have of getting it fixed?

Really quite stressed over this... seems like it's going to be a money pit to solve. Anyone had a similar experience?
User avatar
My Name: Arfur Dent

Guru
Posts: 3546
Joined: Sat Jul 23, 2011 3:47 pm
Model: C3 2002-2005, Original shape model
Year: 2002 (52)
Engine Size: 1.4 (16v)
Fuel Type: Diesel
Mileage: 100000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: DV4 16-valve diesel (90 PS)
Has thanked: 355 times
Been thanked: 139 times

Post

Hi doeboy
doeboy wrote: When I activate them by and large they work. I've had 5 occasions now when I've got in the car on a rainy day and turned them on and nothing. Then 2-6 minutes later when I try again they work. 3 weeks ago when we had some seriously heavy rain they wouldn't turn off. At first they turned off with the ignition off, then they kept going even when the engine was off.
Wiper control is by the COM2000 (steering stalks) then that talks to the BSI (cabin fuse box) and that sends a signal to the BSM (engine fuse box) that operates the wiper motor.

To diagnose this I would use the Lexia clone tool/diagbox (from here). This tool can read signals from the COM2000 and simulate signals in the BSI so you can see if the fault is with the COM2000 or the BSI. If they work, then you will be looking at the BSM or the motor and you would use a multimeter there.

Intermittent faults can take a while to track down because they are very shy and don't often show up when the diagnostics is connected :lol:

We have a topic for using the Lexia tool (here).

Its all quite involved because there are quite a few steps in the process of 'wipe'.

COM2000 is a common failure on older C3s, but I don't know if they have been improved on the A51.

If they don't turn off with the ignition, the BSM and BSI would be more likely to be your problem.
You can add an avatar to your account - Avatar or change your vehicle details - Car Bio or even add a signature to your posts - Signature. But this is not all you can do in the User Control Panel :)
  • Similar Topics
    Replies
    Views
    Last post

Return to “Questions about a Citroen C3 not related to the fuel type”