Won't upshift in Automatic, works perfect in manual

If you have Automatic gearbox problems or issues that would only affect an Auto, please ask here.

Please provide as much information as possible including photos you have taken and uploaded directly to the topic.
Forum rules
One question per topic about an Auto or semi-auto gearbox can be posted in this section
No engine questions
Think: Auto not changing up or down, snowflake/sport flashing, flappy paddles, actuator fault and sensodrive not changing gear.
My Name: Jimaha

Member
Posts: 2
Joined: Tue Jan 31, 2017 7:27 am
Model: C3 2002-2005, Original shape model
Year: 2005 (05)
Engine Size: 1.6
Fuel Type: Petrol
Mileage: 45000
Trim Level: Desire
Gearbox: SensoDrive
DPF: No
LHD or RHD: RHD (UK)

Post

Hey guys,

My girlfriends got a 2005 C3 1.6 pluriel with 45k miles that she inherited from her nan (owned from new) and recently developed this weird gearbox problem.

When in Automatic mode it will not up-shift and hit the rev limiter, however in manual mode the gearbox works perfect and will change gear up and down with both the paddles and shifter.

If I change from Manual to Auto when driving along and come to a stop, it will downshift by itself to 1st no problem.

The dash has the ABS light on and the Spanner on the Speedometer. I've tried the gearbox re-sync thing but the problem remained.

As this is not a major issue she been using the car in manual mode with no issues, but with the MOT coming up now it feels like a good time to try and fix it.


Does anyone have experience with this problem?

Thanks for any help!

james
User avatar
My Name: Arfur Dent

Guru
Posts: 3308
Joined: Sat Jul 23, 2011 3:47 pm
Model: C3 2002-2005, Original shape model
Year: 2002 (52)
Engine Size: 1.4 (16v)
Fuel Type: Diesel
Mileage: 100000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: DV4 16-valve diesel (90 PS)
Has thanked: 259 times
Been thanked: 112 times

Post

Hi Jimaha
Jimaha wrote:When in Automatic mode it will not up-shift and hit the rev limiter, however in manual mode the gearbox works perfect and will change gear up and down with both the paddles and shifter.

If I change from Manual to Auto when driving along and come to a stop, it will downshift by itself to 1st no problem.
It sounds like an electrical fault and the mechanicals seem to be ok from what you have found.
Jimaha wrote:The dash has the ABS light on and the Spanner on the Speedometer
This could be an indication to your problem. ABS signal is used by the gear box ECU. I suggest you connect a lexia tool (from here). This can give you the information you need to fix the ABS fault and when that is clear (repaired, not just fault cleared :lol: :lol: ) road test the car again to verify if the gear selection in auto is corrected.

If you are unaware of the oddities of lexia, read this lexia topic to ensure your laptop is compatible.
Jimaha wrote:As this is not a major issue she been using the car in manual mode with no issues, but with the MOT coming up now it feels like a good time to try and fix it.
It would be beneficial to do the service too, (your Spanner on the dashboard) - cheap enough parts from ECP (here), then clear the spanner with help of this topic to reset the C3 service indicator (here).
Jimaha wrote:Thanks for any help!
Let us know how you get on :)
You can add an avatar to your account - Avatar or change your vehicle details - Car Bio or even add a signature to your posts - Signature. But this is not all you can do in the User Control Panel :)
My Name: Jimaha

Member
Posts: 2
Joined: Tue Jan 31, 2017 7:27 am
Model: C3 2002-2005, Original shape model
Year: 2005 (05)
Engine Size: 1.6
Fuel Type: Petrol
Mileage: 45000
Trim Level: Desire
Gearbox: SensoDrive
DPF: No
LHD or RHD: RHD (UK)

Post

After reading your reply I've just realised i have been having a bit of brain fart all this time. I was interrupting the Spanner as an Engine error :| ...It's just the service indicator :lol:

Well this certainly narrows down the possible causes.

I'll try fixing it this week and and make sure i update this post when its fixed. Hopefully its just a dodgy sensor! :D

Thanks for the help,
User avatar
My Name: Arfur Dent

Guru
Posts: 3308
Joined: Sat Jul 23, 2011 3:47 pm
Model: C3 2002-2005, Original shape model
Year: 2002 (52)
Engine Size: 1.4 (16v)
Fuel Type: Diesel
Mileage: 100000
Trim Level: Exclusive
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: DV4 16-valve diesel (90 PS)
Has thanked: 259 times
Been thanked: 112 times

Post

Jimaha wrote:. I was interrupting the Spanner as an Engine error :| ...It's just the service indicator :lol:
Yes, this one shows the spanner for 'service due' and the engine light identifying an engine sensor fault.
Spanner on the dashboard of a Citroen C3
Spanner on the dashboard of a Citroen C3
Jimaha wrote:I'll try fixing it this week and and make sure i update this post when its fixed.
Thank you.
You can add an avatar to your account - Avatar or change your vehicle details - Car Bio or even add a signature to your posts - Signature. But this is not all you can do in the User Control Panel :)
  • Similar Topics
    Replies
    Views
    Last post