Autobox safemode

If you have Automatic gearbox problems or issues that would only affect an Auto, please ask here.

Please provide as much information as possible including photos you have taken and uploaded directly to the topic.
Forum rules
One question per topic about an Auto or semi-auto gearbox can be posted in this section
No engine questions
Think: Auto not changing up or down, snowflake/sport flashing, flappy paddles, actuator fault and sensodrive not changing gear.
My Name: murdock_bassi

Contributor
Posts: 10
Joined: Sat Dec 01, 2012 7:53 pm
Been thanked: 1 time

Post

Hello All, My mate has an 05 1.4 SX C3 Automatic (not senso drive?) with 50,000 on the clock.

Over the last few months the car has made a beep, the snow and sport lights have both turned on and the car goes into limp mode.

Once she nurses it to the side of the road she can turn the engine off and back on and everything is back to normal.
Also sometimes there is a loud bang (never a good noise to come from a car) from I think the gearbox.

I know the answers Is probably going to be along the lines of 'drop it', 'get another car' etc and I'm prepared to part ex it before it completly dies, but on the off chance its not an expensive fix I will get it fixed.
User avatar
My Name: C3driver52

Guru
Posts: 1854
Joined: Sat Apr 30, 2011 7:40 pm
Model: C3 2002-2005, Original shape model
Year: 2003 (03)
Engine Size: 1.4 i
Fuel Type: Petrol
Mileage: 79984
Trim Level: VTR+
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: TU3 (75 PS)
Has thanked: 85 times
Been thanked: 65 times

Post

Sport and Snow flashing or lighting up on an automatic gearbox found on the C3 are indicating the the gearbox ECU has detected a fault, the locking in a gear is a self preservation attempt and needs to go to Citroen to be diagnosed on the computer system. Continuing to drive and constantly resetting the fault could possibly cause more and more damage (up to the point of total failure or a much more expensive fix).

The automatic gearbox ECU will store the error codes that its found and can reveal them to the diagnostic computer. This would be a good place to start.
murdock_bassi wrote:Also sometimes there is a loud bang (never a good noise to come from a car) from I think the gearbox.
That doesn't sound good, and could be connected to the 'sport and snow' lamps illuminating, or a worn engine mount. Is there any history of previous work on the auto box on that car? You will need to find out when the noise happens (after selecting reverse/forward gear/small bumps in the road/cornering/the list is endless).

murdock_bassi wrote:with 50,000 on the clock
Its got to be worth looking a bit deeper with some diagnostics (sooner rather than later).

There is a tool that runs on an old windows XP laptop that can get the diagnostic codes, called Lexia3 tool here you can find out more about Lexia, here.
My Name: murdock_bassi

Contributor
Posts: 10
Joined: Sat Dec 01, 2012 7:53 pm
Been thanked: 1 time

Post

Thank you for your reply

Chatting to my mate today, aparently the banging noise has only happened 3 times in the last year, and I think it might be the box jumping out of gear (is that feasable?)

The other beeping issue has been ongoing for a year now, has happened about 20 times, but as it cleared on a restart it was largly ignored, with the hope it would go away ;)

I do have an ELM27 bluetooth reader, will it work with the software you mentioned?

I am hoping it is a sensor more than an actual major autobox issue
User avatar
My Name: C3driver52

Guru
Posts: 1854
Joined: Sat Apr 30, 2011 7:40 pm
Model: C3 2002-2005, Original shape model
Year: 2003 (03)
Engine Size: 1.4 i
Fuel Type: Petrol
Mileage: 79984
Trim Level: VTR+
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: TU3 (75 PS)
Has thanked: 85 times
Been thanked: 65 times

Post

murdock_bassi wrote:I do have an ELM27 bluetooth reader, will it work with the software you mentioned?
The lexia is hardware and software, I am sure the software of lexia isn't going to work with the ELM327. But - the ELM327 will talk to the C3 (it does talk to all the petrols and the diesels after about 2004). The thing is, will the ELM get to the automatic gearbox ECU (via the BSI). I think its going to be down to the software you use to run your ELM327, the more the ELM is aware of what to look for, the more it can see.

If you can find some time to have a go with the ELM and the C3, it would be nice to get some feedback on what you can and can't to with the cheaper tools. (Like get gearbox error codes).

murdock_bassi wrote:I am hoping it is a sensor more than an actual major autobox issue
Yes, hoping for a solenoid valve fault.
My Name: murdock_bassi

Contributor
Posts: 10
Joined: Sat Dec 01, 2012 7:53 pm
Been thanked: 1 time

Post

took it to Cirtoen Birmingham, bear in mind this is a main Citroen dealer and not a franchise......

QUOTE: 'We can find nothing wrong, but we do not have the expertise or experiance to diagnose this type of problem' END QUOTE

They updated the Software cleared the (undisclosed) tempary fault codes and said that might clear the problem.... err no it faulted out on the way home....... :cry:

Going to try a fluid change to see if that gives it a few more miles then part exchange it early next year, or take it to a specilist and see if I can throw away upto £600 on a repair.
My Name: osuldavid

Member
Posts: 4
Joined: Mon Apr 15, 2013 9:27 am

Post

Hi,

Did you ever find a solution to this issue?

Did the fluid change help?
My Name: HadeZzz

Member
Posts: 3
Joined: Wed Jan 28, 2015 7:44 am
Model: C3 2006-2009, Facelift model
Year: 2007 (07)
Engine Size: 1.6
Fuel Type: Petrol
Mileage: 90000
Trim Level: VTR+
Gearbox: Automatic PRND
DPF: No
LHD or RHD: LHD (Europe)

Post

Hi all,

My first post here. C3 2007 model, citroen c3 prnd gearbox, 80K. Got the same issue several months now. :( ...The noise, the safe mode... Done resetting the BSI comp (https://citroenc3owners.com/citroen-c3-t ... 3-t69.html) and it worked really well for ..3 days. Now the error comes again (not that regularly , but it will...I know it...)... I'm hopeless :)
User avatar
My Name: C3driver52

Guru
Posts: 1854
Joined: Sat Apr 30, 2011 7:40 pm
Model: C3 2002-2005, Original shape model
Year: 2003 (03)
Engine Size: 1.4 i
Fuel Type: Petrol
Mileage: 79984
Trim Level: VTR+
Gearbox: Manual 5 speed
DPF: No
LHD or RHD: RHD (UK)
Engine name: TU3 (75 PS)
Has thanked: 85 times
Been thanked: 65 times

Post

Welcome to the forum HadeZzz
HadeZzz wrote:.The noise,
I can't hear the noise, but noises are generally a sign of mechanical damage, grinding, knocking, graunching, squealing..... Beeping is a computer error.
HadeZzz wrote:the safe mode...
If you have a mechanical noise, safe mode will be soon to follow because the gear box has detected a fault and is trying to protect itself from further damage.
HadeZzz wrote:Done resetting the BSI comp (citroen-c3-tips/how-to-reset-the-bsi-on-a-citroen-c3-t69.html) and it worked really well for ..3 days.
If the fault is not fixed, it will return.


Best to diagnose the noise and take it from there. Can you record the noise and upload it to youtube?
My Name: HadeZzz

Member
Posts: 3
Joined: Wed Jan 28, 2015 7:44 am
Model: C3 2006-2009, Facelift model
Year: 2007 (07)
Engine Size: 1.6
Fuel Type: Petrol
Mileage: 90000
Trim Level: VTR+
Gearbox: Automatic PRND
DPF: No
LHD or RHD: LHD (Europe)

Post

Hi,

Thanks for the reply. I have downloaded Lexia and I have a friend with the cable so we'll do the diagnostic a.s.a.p. The noise is actually that banging one time noise when the gear goes down with the error itself. If I drive slowly and error comes, there is no sound of it. Anyway..better to check the error code first and I'll update the info here. I've checked this post as well(https://citroenc3owners.com/c3-automatic ... t1238.html), so it could be the same thing. Let's see.

Thanks again!
My Name: HadeZzz

Member
Posts: 3
Joined: Wed Jan 28, 2015 7:44 am
Model: C3 2006-2009, Facelift model
Year: 2007 (07)
Engine Size: 1.6
Fuel Type: Petrol
Mileage: 90000
Trim Level: VTR+
Gearbox: Automatic PRND
DPF: No
LHD or RHD: LHD (Europe)

Post

Hi all,

I'd like to finalize my issue here. We changed the gearbox electrovalve and the oil as per this topic (https://citroenc3owners.com/c3-automatic ... t1238.html) + (https://citroenc3owners.com/tips-for-a-c ... t1254.html) and the videos there (very helpful) and it's all good now. Thank you very much JAGPURR! All the best to all of you!